can't get most spells as ranger?

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • darwin
    Rookie
    • Jan 2024
    • 12

    can't get most spells as ranger?

    When Angband was more like what it came from--Moria--through maybe Angband 2, it was easy to get all spells as a ranger. Now even with maximum intelligence and maximum level (such as testing in wizard mode) seems only one spellbook works, and it says you can learn more 'verses' but no other books work.
  • Nick
    Vanilla maintainer
    • Apr 2007
    • 9585

    #2
    4.2 rangers have changed a lot from previously. They are now WIS based casters, and they only use two (nature) books, a town book and a dungeon book.

    If you really want to play old school rangers, you can copy over old_class.txt into your user directory (~/.angband/Angband on linux) as class.txt, and it will be pretty much as you remember it.
    One for the Dark Lord on his dark throne
    In the Land of Mordor where the Shadows lie.

    Comment

    • darwin
      Rookie
      • Jan 2024
      • 12

      #3
      Couldn't find old_class.txt. What version did this change on?

      Comment

      • Nick
        Vanilla maintainer
        • Apr 2007
        • 9585

        #4
        It should be in lib/gamedata; it has been there since version 4.2.0, when the classes changed
        One for the Dark Lord on his dark throne
        In the Land of Mordor where the Shadows lie.

        Comment

        • darwin
          Rookie
          • Jan 2024
          • 12

          #5
          In the package built the standard way in the script on SlackBuilds.org (I used to maintain, but now a friend does) this file doesn't exist... I'll have to talk to the new maintainer.

          Comment

          • Nick
            Vanilla maintainer
            • Apr 2007
            • 9585

            #6
            Originally posted by darwin
            In the package built the standard way in the script on SlackBuilds.org (I used to maintain, but now a friend does) this file doesn't exist... I'll have to talk to the new maintainer.
            My guess is that that's because it isn't installed by the Makefile.
            One for the Dark Lord on his dark throne
            In the Land of Mordor where the Shadows lie.

            Comment

            Working...
            😀
            😂
            🥰
            😘
            🤢
            😎
            😞
            😡
            👍
            👎